AD044 Discord4 Upgrade From Discord 1/1.5/2/3


Collections: 03 Upgrades



The Discord4 download is 64-bit only. 
Windows 8.1 or greater: VST, VST3, AAX
macOS 10.12 Sierra or greater: VST, VST3, AAX, AU
Linux Ubuntu 18 or greater: VST, VST3

This product is an upgrade, and requires an existing license for Discord 1, 1.5, 2, or 3 for installation and use.

Manual (PDF)



Related Items